Community forums

Setup for Tiny RTK 's base and rover


#22

Hi aj152, ,
I have too a project to retrofit a lawnmower , just at the beginning , I’m waiting for the the electric steering to arrive.


#23

Hi everyone,
i never been able to get my tiny RTK gps to show “dgps” in mission planner.
my setting is the following:
Pixhawk2.1 (firmware 3.5) with first GPS drotek XL GPS ( not the rtk one)
the second GPS is the tiny rtk gps
i used the pixhawk telem 1 (so i soldered the gps on the drone)
i followed the drotek manual but i never get dgps. it is always 3D FiX
on mission planner i succeed to pass the survey mode (setting 100s and 3meter , never succeed to past it at 1m even after more than an hour with blue sky, normal? i’m in europe)
i selected the injects option .
i have the same result if i used only one gps (the tiy rtk gps)
please help
thank you


#24

@Richard9916
Feel free to give your opinion! And we are migrating docs to Gitbook, this will be the occasion to improve them, so comments are welcomed.


#25

So what is exactly the GPS of your base ?
I do not understand


#26

Hi,
the docs are good but it would be nice to have some more information about the different setting , what are they for and what we can change to improve the result we have.
also a trouble shooting guide could be very useful
i know that doing the doc is a very hard and long part of the work.
i really appreciate the work done
thanks


#27

sorry it wasn’t clear.
i have a pair of tiny rtk gps , one for the base and the other on the second gps port of the pixhawk.
and as primary gps on the pixhawk i have the drotek XL gps.
hope it is clearer…
thanks for your help


#28

Remove or disconnect the XL Gps and try with only the Tiny Rover.
Lets make things simpler
When you’ll have your RTK system working as expected you’ll add the second Gps on the Rover.


#29

ok
i removed the drotek xl
now i have only the tiny rtk gps on the drone (gps 1 port) and another connect to my computer and mission planner.
on mission planner the base tiny rtk is going on position valid , i connect MP to the drone but in mission planner i still have GPS 3DFixit never turn to dgps…
i don’t know in which direction to search.

another question , in MP, i have to select inject in telemetry , m8p autoconfig and do i need to select m8p fw 130+ ?

thanks for your help


#30

one more question for the wiring
when i use the telem of pixhawk, how should i wire the tiny rtk gps?
for the moment i connect only the gnd/5vin and the TX and RX on the gps side.
do i have to connect the gnd/ 5v out and TX , RX of the telem out of the gps and connect them to the telem 2 of the pixhawk?


#31

With the latest Mission Planner version the RTK status when receiving satellites can be:
-3D Fix - No RTK datas receives
-RTK Float
-RTK Fixed
Dgps could appear if without RTK datas received DGPS data’s are received but it is not the goal , you should go for RTK status.

M8P FW130+ can be selected if your Tiny RTK have been updated to last Ublox firmware version , by default it is not while it is recommended.

If you have already configured the base for a valid survey in do not select M8P auto config since this option make a new configuration to the RTK base.

The Tiny RTK must be connected simply to the Pixhawk GPS port if you use inject method, you must not connect the Tiny RTK to the telemetry port.


#32

FYI: it looks like SBAS DGPS support was removed for the m8p for some reason, which is too bad since its a nice fallback solution:
https://portal.u-blox.com/s/question/0D52p00008HKD8YCAX/sbas-c94m8p-is-it-possible