Community forums

Setup for Tiny RTK 's base and rover


#1

Dear staff of Drotek,

I tried to set up the two Tiny RTK with my Pixhawk using Mission Planner as a GCS software. But I still can NOT succeed to get the sub-meter level accuracy. The Mission Planner shows “3D GPS Fixed” and never shows the right one “dgps” even after I used the command “Inject GPS” in Mission Planner.

Please tell me the right connection between the ROVER RTK GPS and my Pixhawk board, I insert the ROVER GPS telemetry cable into the “GPS” slot of Pixhawk. It is right? Or should I insert it on to the “SERIES” slot on the PIxhawk?

​Second question is, how to make sure the radio link communication between ROVER and BASE is right? I use a air of 433MHz radio link between Base and Rover and another pair of 915MHz between my PC (Mission Planner) and Pixhawk .

Last question, in the user guide I read a instruction about how to set up ROVER as follows,
" a) Encapsulating raw data in your telemetry link. For this feature the soldering bridge on the board needs to be activated (soldered). " What exactly does SOLDERING BRIDGE mean?

Hope to get your reply ASAP. Thanks. Richard


#2

Hello,

So there are two possible situations, the first one is when you want to use only one telemetry, that means that you want so send over MAVlink all differential data coming from the base (which is connected to Mission Planner). In that case you need to solder the following bridge on the board :

You also need to use the Inject GPS function in Mission Planner.

The other case is when you want to use separate telemetries, one for MAVlink and the other one for differential data. In that case you need to connect TinyRTK’s rover port to Pixhawk GPS port and TinyRTK’s telem port to your second telemetry. In that case Inject GPS function must not be used. Be aware that on TinyRTK rover is configured to work at 38400 baudrate (cf documentation), so your telemetry must work at this baudrate too.

In order to check that messages are consistent, you can plug your base normally and then plug rover’s telemetry to your computer and open U-Center. If you go to View -> Messages View, you can verify whether RTCM messages are correctly sent or not.


#3

Hi Kevin,

Many thanks for your response on my requests. I’ll try out what you suggested and then get back to you when I have the test results.

Cheers,

Richard


#4

Hi Kevin,

Still no success to get the RTK done, I only got 3D Fix, never had dgps on my Mission Planner and the RED LED of the rover never appear. I used a dedicated radio link (both ends with 433MHz) for base to send and receive data to/from rover. My question is: in setting up base and rover, I see two paragraphs talking about how to set the baud rates. (1) Base: " Go to PRT (Port) menu and select a baudrate (usually 57600). Click on Send." (2)Rover" " First connect your rover to U-Center with USB just as you did with your base. Go to View -> Configuration View and select PRT (Port). There make sure to select your flight controller’s GPS baudrate (38400 for Pixhawk) and click on Send. "

Do you think, setting baudrates of base(ublox M8P-2)/rover(M8P-0) as two different values ( 57600/38400) may cause the the communication between base and river troubles?

Another question is how to make sure that rover does receive the GPS correction signal from base?

Cheers,

Richard


#5

Hi Richard,

Pixhawk GPS port works at 38400 bps, so on this side you have to make sure that both your rover and your telemetry are configured at this baudrate. On base side, feel free to configure 38400 or 57600 bps, both should work, but make sure that your telemetry settings do correspond.

To diagnose your setup, first set up your base and its telemetry. Then take the other telemetry and connect it to your computer. Open U-Center, connect to your telemetry and go to View -> Messages View. This program will help you monitor what messages your base is actually sending and at what rate and baudrate. You should see RTCM messages at 1 Hz, your telemetry being read at a baudrate of 38400.


#6

Hi Kevin,

Merry Xmas.

I heard that Galileo system has officially launched recently. I have Tiny RTK (base and rover) and I checked the website of U-Blox (https://www.u-blox.com/en/product/neo-m8p ) and the pecs of Neo-M8P seems not support Galileo. Does it mean that Drotek’s Tiny RTK can’t get the signals from Galileo satellites?
If there is still some chance to get the Galileo signal, what should I do to adjust the parameters of M8P using U-center?

Cheer,

Richard


#7

Hello Richard,

Happy New Year! And sorry for the late reply, lots of work after Xmas holidays. For the moment u-blox is supporting Galileo on M8N and M8T only. It is however very likely that they release a firmware update to give Galileo capabilities for the M8P.

About configuration, you can choose what constellations to use in View -> Configuration View -> GNSS.

Kevin


#8

Hi Kevin,
I have been following this thread…as we are experiencing the exact issue.
We have two pairs of Tiny RTK; one pair configured for GPS Ingest (soldering bridge), the other pair is configured for dedicated telemetry link (unsoldered).

For both configurations I get a 3D GPS Fix very quickly; however this never transitions to a DGPS fix.
We have come to the conclusion that the rover unit is acting as a single receiver (a very good one I might add!), because we can power off the base station with no change in performance.

Could you please tell me if you have ever found a ‘fix’ to the no dgps problem?


#9

Hello,

Are you using Pixhawk?

Keep in mind that there are two possible setups :

Setup 1 :

  • you have (only) one telemetry between your GCS and your flight controller
  • your base is connected to GCS by USB (no matter if it is soldered or unsoldered)
  • GCS is listening to packets from base and puts them into a MAVlink message directly forwarded to FC via the existing telemetry link
  • this is the “injection” setup and requires the bridge to be soldered on rover side

Setup 2 :

  • you have one telemetry between your GCS and your flight controller
  • you have a second and different link for RTK corrections
  • you are using TELEM port on base (no matter if it is soldered or unsoldered)
  • rover needs to be unsoldered and hand-configured corresponding to the instuctions

Which one of the setups are you trying to use?


#10

Hello Kevin, I have the GPS RTK XL Drone Edition. What bridge is to be soldered on this unit please?

Thank you.


#11

Hi,

There is only one solder bridge next to TELEM connector, have you found it?


#12

Hello,

Was anyone able to get the two Tiny RTK modules to work with Pixhawk showing “dgps”?

I’m really interested in this product, but I’ve been waiting since its release for actual clients getting to work with Pixhawk.

Thanks.


#13

It actually work with Pixhawk
Mission Planner shows Dgps because Arducopter firmware prior of version 3.5 do not initialise correctly the M8P gps family .
Look at my older post.


#14

Hi Richard,

Were you able to get your RTK to show “dgps”?

Thanks.


#16

About the telemetry baudrate, it is not clear. Do we need to modify Ardupilot’s telemetry (serial1) port to 38400 instead of the default 57600 ?
And then if it is the case, do we also need to modify the SiK radio configuration to 38400 ?(instead of the default 57600 )


#17

No, 57600 is ok as any other speed of the telemetry if you use the inject system to bring RTK corrections to the rover


#18

If you guys would like to get RTK done on rover side (meaning no injection in Missption Planner of the GCS), it’s better stick with the baurate of 38400 because Pixhawk accepts the GPS signal only by 38400. Yes, I did get the dgps shown on Mission Planner. The manual of Drotek’s Tiny RTK helped, but not perfect. French style, I guess. :slight_smile:


#19

Replied.


#20

Thanks for sharing. I’m using a Pixhawk 2 on a Lawnmower Rover, and i’m hoping the Tiny RTK base and rover modules will help me get a more precise Rover “Flight Plan”, it seems to be the most affordable option so far.


#21

Hi AJ, great to hear that you’re using Tiny RTK to retrofit lawnmower (or build a brand new one?) Just a reminder, if the landscape is somehow curved so that the mower may, at some specific area, drop the GPS correction signal sent from Base, you may consider to install a second Base to cover the shadowed area, making the rover all the way fully covered. As to the affordability, I would suggest you try another device which of course I can’t mention here.
I may order one lawnmower from you once your project succeeds. Enjoy making your innovative lawnmower.
Richard