Community forums

Setting up RTK XL with Pixracer?


#1

Hello,

I’m trying to setup the Drotek “M8P RTK XL + compass” with the Pixracer autopilot and separate RTCM radios (where the base sends RTCM messages directly to the Drotek XL).

As you can see from the attached photo, I have successfully configured the radios (standard 433 MHz telemetry modems from Holybro) and base station to send RTCM to the XL: the XL’s RTK LED flashes red, indicating RTK float. The Rover’s radio is configured for 38400 bps on the serial interface.

I’ve connected the XL’s “Rover” port directly to the Pixracer’s GPS port. I’ve configured the Drotek XL UART1 port to 38400 bps (see u-center image at https://drive.google.com/file/d/0BxppH98F8tSbU0gwc1VtaVhub0E/view?usp=sharing). However, the Pixracer never recognizes the attached XL GPS, never displays any GPS lock, HDOP, number of satellites etc.

I’ve also tried swapping the RX and TX lines on the cable connecting Pixracer to the Rover port. For reference the Pixracer GPS port pinout is here: https://drive.google.com/file/d/0BxppH98F8tSbNTBPWmNXMUhWUWs/view?usp=sharing (The GPS port is on the left above the Baro, in this image.)

What do I need to change in my configuration to get the Pixracer to recognize the XL GPS? To be clear I’m running the latest stable PX4 firmware stack on the Pixracer, not ArduPilot.

Thanks for your help!


#2

Actually it is not possible to have this setup with PX4 Firmware, if you look at the code, the driver tries to configure the GPS and then expects ACK messages from it. As you only have one line connected to the Pixracer, the configuration messages never makes it to the GPS, so there is no ACK message from the GPS to the receiver.

This setup can however work with Ardupilot firmware.

There has a lot of change lately so we will update documentation so that it reflects better nowaday’s possible options.


Tiny RTK Base Connected to a Tablet
#3

I thought on your website it is claimed that RTK XL is compatible with PX4 firmware? Is this only a problem with pixracer? Will the RTK XL work with PX4 on pixhawk autopilot?


#4

RTK XL is perfectly compatible with PX4 firmware, it is the setup with non-MAVlink RTCM corrections that is not possible for the moment.


#5

Thank you for the quick response. I plan on using RTK XL as a Rover(octocopter) with 3DR Pixhawk, px4 firmware (V1.6.0 has this been tested?) and a RTK TINY as a Base with a Tw4721 antenna. Do I still need to solder a bridge on the Rover even if I use the RTK XL? what other components will I need? I am assuming I will still need the JST to DF13 connectors as well.


#6

These functionalities have been integrated in PX4 and Ardupilot for a while and have been tested successfully. Yes you need to solder the bridge on Rover. Differential data will be sent via MAVlink with standard telemetry system so you should have everything you need.


#7

Kevin, thanks for the clarifications.

On a related note, I’ve just received the latest RTK XL and this new hardware version includes a physical switch that switches between “ROVER” and “TELEM”. Can you explain what this switch actually does? From what I can tell, it appears to route the RX pin between ROVER and TELEM. Is this equivalent to soldering the bridge on the older hardware version?

For what it’s worth, I didn’t see any mention of this switch in the RTK XL product documentation or product description (although it is now shown in the product photos in the online store).


#8

Exactly, the switch replaces the solder switch, which wasn’t the best from user perspective. It switches the RX line between TELEM and ROVER connector. We are going through a complete refactoring of our documentation and will add this to it.


#9

I have received an XL RTK with a broken “Rover” to “Telem” switch. Is it possible to still solder the bridge?


#10

Dear Daniel,

Yes you can solder the bridge between rover or Telem pad with the center pad.
Let me know if you need pictures.


#11

Pictures would be great! thank you. My intention is to use the rover setting.


#12


#13

Thank you Kevin!