Community forums

NEO-M8N with highest accuracy


#1

Dear Support Team,

I have a NEO-M8N with the latest firmware (3.01) and I connected to a bluetooth module via UART .I would navigate my RC boat with this setup via Android mobile.

I would set Galileo system as well but I cannot. I tick Galileo configure and enable on GNSS configuration I send and save, but after I reconnect M8N to PC this setting is missing. (and tick is missing). Should I disable some other system on GNSS config? What is the best configuration in Central Europe to get highest accuracy ?

Thank you in advance!
Br
Balazs


#2

Hello,

First of all, did you try to refresh the parameters after changing it ?

Secondly, changing the configuration from the GNSS Configuration panels does not perform a permanent save. You have to change the conf in the Configuration View as you have done and then download the configuration file : Tools -> GNSS Configuration -> GNSS>File, and re-upload it with the “Store configuration into BBR/Flash” option ticked via the File>GNSS button.
Check if it worked by turning your gps off and reading again the settings in the configuraton view.

Finally, if it does not work, make sure you have the latest u-blox center version and try again with QZSS and SBAS disabled.


#3

Hi,

Thanks you! GNSS setting was success with your guidance, but after when I reload GNSS conf from file, Port setting
has been changed from UART1 to SPI. I don’t understand. I’ve tried several times, I re-change PORT , but issue is the same.
I attached current GNSS conf, and PORT settings.I use the latest release of U-Center (8.24)

Do you have any idea, why cannot change the port back to UART1?

Thanks
Br


#4


#5

There’s an other wy of saving the conf to the gps according to the “u-center UserGuide”. Here’s a screenshot.

My version of u-center is 8.23 and my port conf is still UART 1. It’s really strange it’s activated for you, here’s what the documentation says about it :

“The SPI interface is designed to allow communication to a host CPU. The interface can be operated in slave
mode only. The maximum transfer rate using SPI is 1 Mb/s and the maximum SPI clock frequency is 5.5 MHz.
Note that SPI is not available in the default configuration, because its pins are shared with the UART and DDC
interfaces. The SPI interface can be enabled by connecting D_SEL (Pin 2) to ground (see section 3.1).”

Did you make any electrical changes ?

If you kept the original config (before changing the config) you can try re-uploading it. Otherwise, I am quite helpless :confused:

Sylvan.


#6

Sorry I cannot add the screen shot, take a look at pages 58 and 59 of the user guide.

Moreover, do you really plan to use IMES (http://gpsworld.com/wirelessindoor-positioningopening-up-indoors-11603/) ? If not, I suggest to disable it.


#7

Hi,

Thnaks for the support, I am ready with the configuration of Galileo with one of them our NEO-M8N, (I disabled IMES system)
I would send GPS data through Bluetotth connection to Android phone. I want to use Atnel BTM-222 Bluetooth module for this. Do you have idea what is the exact port configuration for this connection? BTM-222 is communicating with PC via UART with only 19200 baud rate. What would be the exact config on NEO-M8N port config surface.

Thanks
Br
Balazs